SUMMARY = "Run a subprocess in a pseudo terminal"
|
HOMEPAGE = "http://ptyprocess.readthedocs.io/en/latest/"
|
SECTION = "devel/python"
|
LICENSE = "ISC"
|
LIC_FILES_CHKSUM = "file://LICENSE;md5=cfdcd51fa7d5808da4e74346ee394490"
|
|
SRCNAME = "ptyprocess"
|
|
SRC_URI[sha256sum] = "5c5d0a3b48ceee0b48485e0c26037c0acd7d29765ca3fbb5cb3831d347423220"
|
|
inherit pypi setuptools3
|
|
UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
|
|
S = "${WORKDIR}/${SRCNAME}-${PV}"
|
|
RDEPENDS:${PN} = "\
|
${PYTHON_PN}-core \
|
${PYTHON_PN}-fcntl \
|
${PYTHON_PN}-terminal \
|
${PYTHON_PN}-resource \
|
"
|
|
BBCLASSEXTEND = "native nativesdk"
|
|
inherit ptest
|
|
SRC_URI += " \
|
file://run-ptest \
|
"
|
|
RDEPENDS:${PN}-ptest += " \
|
${PYTHON_PN}-pytest \
|
${PYTHON_PN}-fcntl \
|
${PYTHON_PN}-terminal \
|
${PYTHON_PN}-resource \
|
"
|
|
do_install_ptest() {
|
install -d ${D}${PTEST_PATH}/tests
|
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
|
}
|