SUMMARY = "Provides cryptographic recipes and primitives to python developers"
|
HOMEPAGE = "https://cryptography.io/"
|
SECTION = "devel/python"
|
LICENSE = "Apache-2.0 | BSD-3-Clause"
|
LIC_FILES_CHKSUM = "file://LICENSE;md5=bf405a8056a6647e7d077b0e7bc36aba \
|
file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
|
file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b"
|
|
LDSHARED += "-pthread"
|
|
SRC_URI[sha256sum] = "5a60d3780149e13b7a6ff7ad6526b38846354d11a15e21068e57073e29e19bed"
|
|
SRC_URI += " \
|
file://run-ptest \
|
file://h-test.patch \
|
"
|
|
inherit pypi setuptools3
|
|
DEPENDS += " \
|
${PYTHON_PN}-cffi \
|
${PYTHON_PN}-cffi-native \
|
${PYTHON_PN}-asn1crypto \
|
${PYTHON_PN}-six \
|
"
|
|
RDEPENDS:${PN} += " \
|
${PYTHON_PN}-cffi \
|
${PYTHON_PN}-idna \
|
${PYTHON_PN}-asn1crypto \
|
${PYTHON_PN}-setuptools \
|
${PYTHON_PN}-six \
|
"
|
|
RDEPENDS:${PN}:class-target += " \
|
${PYTHON_PN}-cffi \
|
${PYTHON_PN}-idna \
|
${PYTHON_PN}-numbers \
|
${PYTHON_PN}-asn1crypto \
|
${PYTHON_PN}-setuptools \
|
${PYTHON_PN}-six \
|
${PYTHON_PN}-threading \
|
"
|
|
RDEPENDS:${PN}-ptest += " \
|
${PN} \
|
${PYTHON_PN}-cryptography-vectors \
|
${PYTHON_PN}-iso8601 \
|
${PYTHON_PN}-pretend \
|
${PYTHON_PN}-pytest \
|
${PYTHON_PN}-pytz \
|
"
|
|
inherit ptest
|
|
do_install_ptest() {
|
install -d ${D}${PTEST_PATH}/tests
|
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
|
install -d ${D}${PTEST_PATH}/tests/hazmat
|
cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
|
}
|
|
FILES:${PN}-dbg += " \
|
${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
|
"
|
|
BBCLASSEXTEND = "native nativesdk"
|