SUMMARY = "Foreign Function Interface for Python calling C code"
|
HOMEPAGE = "http://cffi.readthedocs.org/"
|
LICENSE = "MIT"
|
LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
|
DEPENDS += "libffi ${PYTHON_PN}-pycparser"
|
|
SRC_URI[sha256sum] = "c9a875ce9d7fe32887784274dd533c57909b7b1dcadcc128a2ac21331a9765dd"
|
|
inherit pypi setuptools3
|
|
RDEPENDS:${PN}:class-target = " \
|
${PYTHON_PN}-ctypes \
|
${PYTHON_PN}-io \
|
${PYTHON_PN}-pycparser \
|
${PYTHON_PN}-shell \
|
"
|
|
BBCLASSEXTEND = "native nativesdk"
|