# Simple initramfs image. Mostly used for live images.
|
DESCRIPTION = "Small image capable of booting a device. The kernel includes \
|
the Minimal RAM-based Initial Root Filesystem (initramfs), which one can use \
|
to check the hardware efficiently."
|
|
PACKAGE_INSTALL = "initramfs-debug busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
|
|
# Do not pollute the initrd image with rootfs features
|
IMAGE_FEATURES = ""
|
|
export IMAGE_BASENAME = "initramfs-debug-image"
|
IMAGE_LINGUAS = ""
|
|
# Some BSPs use IMAGE_FSTYPES_<machine override> which would override
|
# an assignment to IMAGE_FSTYPES so we need anon python
|
python () {
|
d.setVar("IMAGE_FSTYPES", d.getVar("INITRAMFS_FSTYPES"))
|
}
|
|
inherit core-image
|
|
IMAGE_ROOTFS_SIZE = "8192"
|
IMAGE_ROOTFS_EXTRA_SPACE = "0"
|
|
BAD_RECOMMENDATIONS += "busybox-syslog"
|